Kwetsbaarheid CVE-2013-7040

Python 2.7 Before 3.4 Only Uses The Last Eight Bits Of The Prefix To Randomize Hash Values, Which Causes It To Compute Hash Values Without Restricting The Ability To Trigger Hash Collisions Predictably And Makes It Easier For Context-dependent Attackers To Cause A Denial Of Service (CPU Consumption) Via Crafted Input To An Application That Maintains A Hash Table. NOTE: This Vulnerability Exists Because Of An Incomplete Fix For CVE-2012-1150.

Algemeen

CVE
CVE-2013-7040
Leverancier(s) betrokken
- Python
- Apple
Omschrijving
Python 2.7 Before 3.4 Only Uses The Last Eight Bits Of The Prefix To Randomize Hash Values, Which Causes It To Compute Hash Values Without Restricting The Ability To Trigger Hash Collisions Predictably And Makes It Easier For Context-dependent Attackers To Cause A Denial Of Service (CPU Consumption) Via Crafted Input To An Application That Maintains A Hash Table. NOTE: This Vulnerability Exists Because Of An Incomplete Fix For CVE-2012-1150.
Publicatie
Maandag, 19 Mei 2014
Gewijzigd
Maandag, 28 November 2016 22:21
Ernst
Medium

Score

Score
4.3
    - Basis
4.3
    - Impact
2.9
    - Misbruik
8.6

Risicoprofiel

CVSS V2 Vector
(AV:N/AC:M/Au:N/C:N/I:N/A:P)

Toegankelijkheid
Netwerk Een kwaadwillende derde kan dit beveiligingslek misbruiken zonder lokale systeem- of netwerktoegang te hebben.
Complexiteit
Gemiddeld Er is enige planning en geluk (bijvoorbeeld het gehoor geven aan phishing-mails door het slachtoffer) nodig voor een kwaadwillende derde om dit beveiligingslek te kunnen misbruiken.
Authenticatie
Geen Een kwaadwillende derde hoeft zich niet te authenticeren om in het systeem te komen om misbruik te maken van dit beveiligingslek.
Configuratie
Geen Een kwaadwillende derde kan dit beveiligingslek niet misbruiken om vertrouwelijke informatie van het systeem te halen.
Integriteit
Geen Als een kwaadwillende derde dit beveiligingslek succesvol weet te misbruiken, heeft dit geen gevolgen voor de systeemintegriteit. De informatie op het systeem blijft betrouwbaar en onaangetast.
Beschikbaarheid
Gedeeltelijk Als een kwaadwillende derde dit beveiligingslek succesvol weet te misbruiken, wordt de beschikbaarheid van het systeem gedeeltelijk beperkt. Het systeem presteert zwakker of is nog maar beperkt te bereiken.

Getroffen programmatuur

Leverancier Software Versie
python python 3.3 beta2
python python 3.3.5 rc2
python python 3.3.5 rc1
python python 3.3.5 -
python python 3.3.4 rc1
python python 3.3.3 rc2
python python 3.3.3 rc1
python python 3.3.2
python python 3.3.1 rc1
python python 3.3.0
python python 3.2 alpha
python python 3.2.5
python python 3.2.4
python python 3.2.3
python python 3.2.2
python python 3.2.2150
python python 3.2.1
python python 3.2.0
python python 3.1
python python 3.1.5
python python 3.1.4
python python 3.1.3
python python 3.1.2
python python 3.1.1
python python 3.0
python python 3.0.1
python python 2.7
python python 2.7.7
python python 2.7.6
python python 2.7.5
python python 2.7.4
python python 2.7.3
python python 2.7.2 rc1
python python 2.7.2150
python python 2.7.1 rc1
python python 2.7.1150
apple mac os x 10.10.4

Referenties

Modificatie geschiedenis

Geef hieronder je email adres op en word op de hoogte gehouden van aanpassingen aan deze CVE